home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / net-dialup / minicom-2.1-r2 / minicom-2.1-r2.ebuild < prev    next >
Text File  |  2006-05-01  |  1KB  |  57 lines

  1. # Copyright 1999-2006 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/net-dialup/minicom/minicom-2.1-r2.ebuild,v 1.8 2006/03/28 18:34:07 vapier Exp $
  4.  
  5. inherit eutils flag-o-matic
  6.  
  7. DESCRIPTION="Serial Communication Program"
  8. HOMEPAGE="http://alioth.debian.org/projects/minicom"
  9. SRC_URI="http://alioth.debian.org/download.php/123/${P}.tar.gz"
  10.  
  11. LICENSE="GPL-2"
  12. SLOT="0"
  13. KEYWORDS="~alpha ~amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86"
  14. IUSE=""
  15.  
  16. DEPEND=">=sys-libs/ncurses-5.2-r3"
  17. RDEPEND="${DEPEND}
  18.     net-dialup/lrzsz"
  19.  
  20. src_unpack() {
  21.     unpack ${A}
  22.     cd "${S}"
  23.     # solar@gentoo.org (Mar 24 2004)
  24.     # propolice/ssp caught minicom going out of bounds here.
  25.     epatch "${FILESDIR}"/${P}-memcpy-bounds.diff
  26.     epatch "${FILESDIR}"/${P}-gcc4.patch
  27.     epatch "${FILESDIR}"/${P}-gentoo-runscript.patch
  28. }
  29.  
  30. src_compile() {
  31.     # avoid lazy binding (minicom is sgided)
  32.     append-ldflags $(bindnow-flags)
  33.  
  34.     econf --sysconfdir=/etc/${PN} || die "econf failed"
  35.     emake || die "emake failed"
  36. }
  37.  
  38. src_install() {
  39.     einstall || die "einstall failed"
  40.  
  41.     #minicom must be uucp sgided is needed for being able to lock serial ports
  42.     #when run as simple user
  43.     fowners root:uucp /usr/bin/minicom
  44.     fperms g+s /usr/bin/minicom
  45.  
  46.     dodoc doc/minicom.FAQ
  47.     insinto /etc/minicom
  48.     doins "${FILESDIR}"/minirc.dfl
  49.  
  50.     dodoc AUTHORS ChangeLog NEWS README
  51. }
  52.  
  53. pkg_preinst() {
  54.     [[ -s /etc/minicom/minirc.dfl ]] \
  55.         && rm -f "${IMAGE}"/etc/minicom/minirc.dfl
  56. }
  57.